Tout d'abord, configurez votre sources.list avec ce que vous devriez avoir installé. Cela devrait être dapper sans "security", "updates" ou "backport" (ndt : sécurité, mises à jour ou rétro-portages). Puis faites :

 apt-get install apt-show-versions
 apt-show-versions -a |
  fgrep -f <(apt-show-versions | fgrep 'newer than version in archive' | cut -d' ' -f 1) |
  grep dapper$ | sed -e 's/\t/=/;s/\t.*$//' |
  xargs apt-get install --yes --force-yes

Il s'agit évidemment d'une commande potentiellement dangereuse.

Builder.fr/RemovingUpdatedPackages (last edited 2008-06-02 07:27:41 by pitof)