Outdated documentation

This page is out of scope. GIMP already has a user manual.

GIMP 2.4.6

GIMP expanded as GNU Image Manipulating program is a powerful tool for tweaking, creating, and playing with images. GIMP is not designed to be a simple paint tool, but as the expansion suggests, it is a sophisticated program for image manipulation. Definitions for the GIMP apart, this page focuses on letting you know about the simple and frequently used tasks that you will do with the help of GIMP. This page doesn't strive to be a comprehensive guide to learning GIMP. You must see this page as a starter, after this page, if you have time and energy, you may venture reading the GIMP official documentation, which is a comprehensive guide to learn GIMP. If you wish to straightly go ahead with the official GIMP documentation, please go to the bottom of this page to get a copy of the documentation for yourself.

The GIMP Interface.

The general opinion is that the GIMP's interface is not very intuitive, but is only a matter of time, you'll get acquainted with GIMP as you use it.

When you open GIMP, from Applications --> Graphics --> GIMP Image editor or from the terminal by typing gimp in the prompt and hitting Enter, two windows boxes open up initially.

The window on the left contains two dialog boxes - the Tool box and the Tool Options box. The Tool box is a repository of the significant tools available in GIMP. You can select one by clicking on it. The Tool Options box shows you the options available for the presently selected tool. For instance, if you select the Airbrush Tool, the Tool Options box shows a options which enable you to select the type,the size (scale), the rate, pressure of the Airbrush Tool.

The window on the right contains a couple of tabbed dialog boxes, both at the top and bottom. At your whim it is possible to add/remove tabbed dialog boxes. The dialog boxes at the top pertain to the characteristics of the active image window, by default, the Layer, Channel,Paths and Undo dialog boxes are present at the top. The details of these dialog boxes and more are covered in the subsequent sections. The bottom ones lets you choose the colors, patterns and the brushes for the paint tool that your using.

When you open or create a new image, the image is put in a separate window. The image window has a menu bar in top from which all of the tools and other things available in GIMP can be selected/opened. There is a small zoom icon placed at the top right corner of the image window. When this option is active, the image automatically resizes along with the image window (for instance, when the image window is maximized or minimized), so that the whole image is visible in the image window. At the bottom of the image window, the zoom level of the image can be adjusted. In the bottom left is a little dotted rectangle. This is a toggle for the Quick Mask, which can also be enabled/disabled with Shift+Q. Details about the Quick Mask feature is discussed in the Selection section.

Layers

In GIMP, you may sketch your drawings in different canvases and in the end merge them together to form a cohesive whole. For instance, if you set out to draw a simple landscape using GIMP, you may choose to paint the mountains and valleys in one canvas, the sky in another, the river flowing beside the mountain in the third, the boats floating on the river in the fourth canvas and so on. This set of canvases are called Layers in GIMP. You may imagine each Layer in GIMP as a canvas. An image can have any number of layers and each layer as its set of characteristics. The characteristics of the layer include its dimensions, its transparency, its visibility, its name, its position with respective to other layers in the image. Before I delve into the details of the characteristics of layers, I want to make you aware that the easiest (perhaps, the only) way to manipulate/tweak layers is from the Layers Dialog box which is present in the right window on the top and is usually the first of the tabbed dialog boxes. The Layer Dialog box is segmented into three parts -- the top part of the dialog box lets you tweak the layer mode and the transparency; the middle part of the dialog box lists the layers of the image; the bottom part of the dialog box contains a couple of buttons which lets you duplicate, delete and create new layers. These are some interesting layer properties:

Paths

There are times when you want to sketch abstract or irregular shapes and you desire to dictate the intricacies of the abstract shape - the curves, the position, etcetera. The Paths feature in GIMP allows you to do exactly this. That Paths feature, first allows you to design the path (your abstract shape) even before you actually sketch it. You may use any of the available paint tools to sketch the designed path.

To start off with the Path tool, you must select the Path tool ( path_tool.jpg ) from the Tool box or just hit B to select it. Now you're ready to fiddle with Paths. After you select the Path tool, your mouse pointer changes to a curvy icon. When you click on the canvas, a small region will appear on the canvas. This is the Anchor. Move the pointer to a different region on the canvas and click. You will see a new Anchor at that point connect to the previous Anchor. This forms a basic Path. Just keep clicking on the regions of the canvas to form a complex or a bigger Path. So, that is about getting a Path sketched out on the canvas. Now on to the curves. The line connecting any two Anchors can be twisted and bent in any way using Handles. Move your pointer over to the line, you will observe that the + near the pointer changes to a pair thick cross arrow. Now click and drag the to bend the line into a curve. Once you have the curve, two white squares will project out from the Anchor. These squares are called the Handles. You may use the Handle(s) to tweak the curve.

Here is an abstract Path that I sketched using the Paths feature :

paths_illustration.jpg

The purpose of creating Paths is to color or trace the path with a painting tool. We call this stroking the path. You may stroke the Path either with any one of the paint tools or you may choose to use a Line style to frill your path. To do this, hit the Stroke Path button in the Tool Options dialog box of the Path tool. A new window pops up. You have two different options to go with (as I have told) -- Stroke a line or Stroke with a paint. With Stroke a line, it is possible to produce a solid line or a pattern line. For the pattern, GIMP provides a Line style sub option which lets you choose the cap & join style, miter limit, dash pattern and dash preset. With the Stroke with paint tool option, you may sketch the Path using any one of the paint tools available in GIMP. Make sure that you set the options for the specific paint tool before you choose to use the paint tool to sketch the Path by hitting the Stroke with the paint tool radio button and hitting OK from the dialog box.

The abstract Path looks like this after stroking the Path with the AirBrush paint tool :

paths_illustration_colored.jpg

Channels

Every image that this used in GIMP has a particular type of color mode. In GIMP we have 3 types -- RGB, Grayscale and Indexed. The color modes can be changed for a the given image by going to Image --> Mode from the menu bar of the image window. The right window that holds a tabbed section in the top, has a Channel tab by default (unless you have meddled with the configuration of the window) from where you may manipulate the selected color mode. You may switch to the Channel window by hitting the Channels tab (channels_tab.png) icon in the tabbed section of the right window. This section allows you to adjust the attributes and gives information about the selected color mode. For instance, if the presently selected image is in RGB color, then the Channels window contains three highlighted channels ,viz, Red, Green and Blue. These highlighted channels describe the channel's attributes. The eye icon (layers_eye.jpg), itched on each of the channels, can be used to enable/disable the respective channel from the selected image.Beside the eye icon is a small thumbnail for each of the channels. This thumbnail is a grayscale representation of the amount of the particular channel's color in the image. Whiter parts of the thumbnail illustrates regions in the image which have shades of the respective channel's color, the black region in the thumbnail indicates the absence of the respective channel's color in the image. For instance, Lets take the below image, which has three different color stripes -- red, blue and green. The image is also specked with a transparent area in the middle.

channels_rgbimage.jpg

As you can see, the image has three distincts colors. Now when you look at the color channels for this image. In the Red channel, the thumbnail renders the topmost area in white and the other parts of the image is dark. By the same token, for the blue and green channel's thumbnail, the middle region and the bottom are rendered in white in the respective channels and the other regions of the corresponding thumbnails are darker. The general rule of the thumb of the grayscale image illustrated is that the regions containing shades of the respective channel's color are rendered in various shades of white, more prominent a particular color is, whiter it is rendered in the thumbnail of the respective color channel. Below, is a screenshot of the Channels dialog box for the above image.

channels_recregion.jpg

For certain images we have a fourth (optional) channel called the Alpha channel which, through its thumbnail, gives information about the transparent & opaque regions of the image. The transparent regions in the image are rendered black in the Alpha channel's thumbnail and the opaque (the visible regions) region of the image are rendered in white as is evident from the above screenshot. The middle region of the above image is specked with transparent parts, these parts are rendered black in the Alpha channel's thumbnail as expected.

Disabling a particular color channel strips the image of that particular variation of the color, if the Red channel is disabled by hitting the eye icon layers_eye.jpg of the Red channel, then pixels of the selected image become devoid of all shades of the red color and when something new is painted onto the image after disabling the Red channel, the color of the paint will also be devoid of all shades of red. To re-enable a particular channel, just hit the space where the eye icon was, the eye manifests again on the Red channel's space and thus the Red channel is enabled again and regions having shades of red become prominent again.

Common Tasks

Scaling an image

In lay terms, scaling an image means "to change the size of an image". You may want to scale an image in order to put it as an avatar in identi.ca or you may want to include an image in your blog post, but the size of the image is simply discouraging you from doing so and thus there is that dire need to scale (adjust the size of) the image to accommodate it in your super awesome blog post. Or you might want to include image x in image y but image x is too large. In this and many other scenarios, there will be this absolute requirement to scale the image. The GIMP allows you to do scaling in pretty simple steps.

To scale an image, first you have to open it. To do exactly this, either hit Ctrl+O or use your mouse to navigate to File --> Open. This should bring up a dialog box. With the help of this dialog box, cruise to the destination where you have stored the image (which you want to scale), click on the image and hit the Open button at the bottom of the dialog box. This should open the image in a new GIMP window. To scale this very image, first you have to choose the Scale Tool. You may choose it either by clicking the Scale Tool icon ( scale_icon.jpg ) present in the Tool Box or by using the keyboard shortcut - Shift+T. Once you do this, a new dialog box will come up. This new dialog box is called Scale. You can either scale the image by using this dialog box or by using the mouse pointer. If you choose to do the latter, then click on the image and move the mouse to scale the image. As you click on the image and move your mouse, instantaneously, a preview of the scaled image is rendered in real time. When you're satisfied with dimensions of the scaled image, hit the Scale button in the Scale window to make the changes. Snap! You have scaled the image. As I have suggested before, scaling can be done using the width and height parameters in the Scale window. You may desire to maintain the aspect ratio of the image. In this case, hit the aspect button in the scale window. I have focused the button with a red rectangle in the image below. The button resembles a chain. When the chain is closed, it means that when you scale the image, the aspect ratio is maintained. When the chain is opened, the aspect ratio is not maintained.

scale_window.jpg

Most of the times, when you scale an image, you reduce the size (i.e the dimensions) of the image. Here, after scaling, you will see a lot of empty space (the grey, black squares). This is the canvas that the original image was laid on. In order to shrink the canvas to exactly fit the newly scaled image, from the menu bar of the image window, go to Image --> Fit Canvas to Layers. This should shrink the canvas to contours of the scaled image. Now that you have scaled the image, it is time for saving a copy of it to your disk. You must note that everything that has happened now is put up in the memory and not written to the disk. To save a copy, hit File --> Save As, in the new dialog box, navigate to the location where you desire to save this scaled image, give the image a name under the Name field, in the dialog box, with the desired extension of the image format you'd like to save it in (jpg or png should be fine) and finally hit the Save button to save the image. You will be prompted with a couple of dialogs according to the image format you have chosen to use for this scaled image. Click through them and you're done with scaling.

Cropping part of an image

When you want to use only a part of an image, cropping comes into play. The GIMP allows you to crop images in a very precise manner. Let me pick an image from my digital shelf and show you how cropping works with GIMP. This image turns out to be a screenshot of my desktop, with an Eye of GNOME window showing an image of Josh Woodward playing a guitar. Now using GIMP's cropping feature, we will crop the Eye Of GNOME window out of the screenshot. I had recently used this image (the screenshot) in GIMP. GIMP keeps a list of recently opened documents under File --> Open Recent. Since I had opened the image recently, I directly head to this place to open my image (the screenshot). joshw_shot.png opens up in a new dedicated window after this.

What are we up to? Mmmm, Cropping. Yes, to crop we need to choose the crop tool ( crop_icon.jpg ). You may either select the crop tool from the tool box or use the keyboard shortcut - Shift+C. As soon as I select the crop tool, the mouse pointer changes to a image of four non-crossing lines perpendicular to each other and below the lines is a small image of knife (which signifies that you're using the cropping tool). Now I move the pointer to the image, click and (without releasing the mouse button) move the pointer to approximately cover the Eye of GNOME window which I desire to crop and once I make this approximate selection of my cropping space, I release the mouse button. Everything except the selection is darkened out. To make my selection more precise, I use the Tool Options dialog (the one below the Tool Box) box. There are two options in this dialog box - the Position and the Size. The Position option allows me to move the selection and the Size option helps me to adjust the dimension (width and height) of the selection. As you may see, these two options have two parameters. For the Position option, the first parameter is used for horizontal movement of the selection and the second parameter for vertical movement. For the Size option, the first parameter is there for adjusting (increasing or decreasing) the width of the selection and the second parameter for adjusting the height.

I use these two options to make my selection more precise. Here is a screenshot of a portion of my initial selection.

approx_selection.jpg

As you can see, the selection is haphazard with the selection line a few pixels off covering a bit of the background in the left edge and in the top, the selection lines fail to cover part of the window border. To get a clear view of the imperfect selection, I zoom in (Ctrl + +).Then, I use the Position option and the Size option to make the selection lines cover only the Eye of GNOME window. After I tweak the selection using the options, the selection looks like this:

perfect_selection.jpg

Now I zoom out (Ctrl + -), have a look at the selection for the last time, move my pointer to the middle of the selection and I click on it. Tadah! I have cropped the Eye of GNOME window. Instead of clicking on the selection to crop, you may hit Enter to crop the image.

Selection

The selection feature in GIMP allows you to choose a region of space in the image. Once you are done with the selection with the help of one of the Selection tools available in GIMP, your selection is depicted with dashed lines. To get a clear view of the selection that you made, you may toggle the Quick Mask button at the lower left corner of the image window. When the toggle is ON, everything except the selection is reddened out. Now after the selection, the portion inside the dashed lines is your workspace, i.e. here is where you can meddle with the coloring tools. The region outside the selection is unaffected by the coloring tools even if you try to paint over them. The boundary which separates the selected region and the un-selected region is usually sharp, meaning, the transition between the selected and un-selected region is abrupt. To smoothen this abruptness of the boundary, you can use Feathering. After you are done with the selection, you may go to Select --> Feather to choose the magnitude of feathering, you may use the Quick Mask toggle to feel the difference between an ordinary sharp selection and the feathered selection.

Selection tools allow you to focus and edit a particular region of space in an image. There are different types of selection tools available in GIMP: Rectangle Select tool, Ellipse Select tool, Fuzzy select tool, Scissor select tool, Foreground Select tool and Select by Color tool. In the sub-sections that follow, I will try to elaborate on the significant ones.

Rectangle Select Tool

As the name is pretty obvious, the Rectangle Select tool ( rectangle_icon.jpg ) allows you to select a rectangular region in the image (or the canvas) on which you are manipulating. You may choose the rectangular region by either hitting the Rectangle Select tool icon present in the Tool Box or by using the R keyboard shortcut. You may also select the rectangle select tool from the menu bar (Tools --> Selection tools --> Rectangle select). To sketch a rectangular selection in the image (or the canvas) that you're editing, just click on it with the mouse and drag the pointer to get the desired shape. The Tool Options dialog box (the one below the Tool Box) has a couple of parameters and options available for this very tool. The Size option shows the width and the height (in order) of the rectangular region you have selected on the image (or canvas). This option will be of help if you're size conscious about the rectangle region. If you intend to get a square, instead of a rectangle, then, as soon as you click on the canvas, keep pressing the Shift key and move the mouse to get a square - a region with equal width and height.

Common uses

After you have selected a rectangular region using the Rectangle Select tool, all of the paint tools that are available in GIMP work (or are active) only in the rectangular region. If you try to paint outside the region nothing really happens. I leave it as an exercise for you to experiment with the paint tools on the rectangular region.

Using this rectangular selection, it is possible to sketch a geometrical rectangle. This geometrical rectangle will have the dimensions equal to the values that are specified in the Size option in the Tool Options dialog box. To draw a geometrical rectangle, you need to Stroke the path, i.e. paint along the path defined by the boundaries of the rectangular region, to Stroke, hit Edit --> Stroke Select from the image window. A new Stroke Selection window will pop up. Here you're provided with two options - Stroke a line and Stroke with Paint tool. The Stroke a line option allows you to choose the width of the line, the line style, whether you want the line to be a solid color or a pattern. Tweaking the line style will allow you to (1)choose whether you want a simple line continuous line or one of the various styles of dotted lines,(2)the cap style and the (3)join style. The Paint Tool option allows you to choose one of the paint tools available for stroking the path (the rectangular contours of the selection). If you plan to select the Paint Tool option to stroke, be sure to set the options for the respective paint tool before hand. When everything is set and done in the Stroke Selection window, hit the Stroke button. Snap! You have the desired rectangle.

It is also possible to fill the rectangular region with the Bucket Fill paint tool ( bucketfill_icon.jpg ). By fill, I mean that the Bucket Fill tool paints inside the rectangular region. You may fill the rectangular region with the foreground/background color or a pattern. To fill the given (rectangular) region using the Bucket Fill tool, first select the tool from the Tool Box or by using the keyboard shortcut Shift+B. After this, you must choose the type of fill. If you want the (rectangular) region to be filled with the foreground color, you don't have to do anything, just move your mouse to the (rectangular) region and click and your region is filled. If you want the (rectangular) region to be filled with the background color instead, just keeping pressing the Ctrl key while you click on the region. If you want to use a pattern fill instead, go to the Tool Options dialog box (below the Tool box, on your left) and select the Pattern Fill radio button under the Fill Type section.

Ellipse Select Tool

This tool can be used to select a circular/elliptical region in the image (or the canvas). You may trigger this tool by either clicking Ellipse Select tool icon ( ellipse_icon.jpg ) from the Tool Box or by hitting the keyboard shortcut E. This tool has mostly the same functionality and functions as the Rectangular Select tool. The functions/features specific to Ellipse Select tool are briefed in the following sub-section.

Common uses

The Anti-aliasing option can be used in tandem with this selection tool. When you anti-alias a selection, it smooths out the curves of the selection and as a result makes the transition from the elliptical selection to the background more gradual (or progressive). If you plan to cut the elliptical selection and paste it somewhere else, the anti-aliasing feature is not recommended, as the anti-aliasing is done with respect to the background of the image in which the selection was made. If you're going to paste this selection in an another image, the smoothing which was done for image A may not suit image B in which the selection is pasted. So try to avoid using the anti-aliasing feature when you desire to cut the selection and put it somewhere else.

This was the elaboration for the Anti-aliasing that is given in the glossary of the official GIMP documentation :

Antialiasing is the process of reversing an alias, that is, reducing the jaggies. Antialiasing produces smoother curves by adjusting the boundary between the background and the pixel region that is being antialiased. Generally, pixel intensities or opacities are changed so that a smoother transition to the background is achieved. With selections, the opacity of the edge of the selection is appropriately reduced.

To select a circular area, hold the Shift key while dragging the mouse. At times you won't get a perfect circle when using this procedure, so always double check whether both the parameters (width and height) of the Size option, in the Tool Options dialog box, have the same values.

Fuzzy Select Tool

The Fuzzy Select tool allows you to select a region in the image (or the canvas) whose pixels are similar in property. You may activate the Fuzzy Select tool either by hitting the Wand icon ( fuzzy_icon.jpg ) from the Tool box or by hitting the key board shortcut U.

Common uses

The Fuzzy Select tool is very different from other selection tools. As the name suggests, it not always possible to do accurate selections using this tool - it is fuzzy. The selection using this tool involves a single click, that is all. Where you want to click depends directly on what shade of color you intend to select. Let us take an image and look how this selection tool works. In the image below, we have four rectangles in 3 different colors.

fuzzy_select.jpg

The fuzzy tool becomes useful in the situation wherein we intend each rectangle to have different colors. The obvious solution to this is to select a rectangle and change its color. Since it is a rectangle, we may be driven to use the Rectangular Select tool to do the selection, but since the rectangle has a color, it is easy to use the Fuzzy Select tool to select the rectangle. Now, to select the rectangle at the top (the red one), all we have to do is first activate the Fuzzy Select tool (hit U), move the pointer to the rectangle and click on it. Snap! We have selected the whole rectangle. Let me explain what exactly happens here. When we click on a particular point of the image, the Fuzzy Select tool gets the properties of the pixel on which we clicked and selects the pixels with similar properties which are in the proximity of the pixel we selected. We can adjust the extent of the proximity by exploiting the Threshold option in the Tool Options dialog box. The extent of the selection is directly proportional to the value of the Threshold. On to coloring the selected rectangle. Since we wish to color the whole selection, the Bucket fill paint tool is the best option. First select this tool with Shift+B, select the desired color, click on the selected rectangle and we have done our deed to have rectangles with different colors.

fuzzy_select_diff.jpg

The Fuzzy Select tool is a good option in order to select a contiguous region in the image with similar pixel properties, but it is not the best bet if you intend to select regions in the whole image with same pixel properties, the Select by Color Select tool is conducive for this purpose.

Select by Color Tool

The Select by Color tool, unlike the Fuzzy Select tool, selects regions based on color similarity. You may activate this tool either by hitting on the Select by Color icon ( selectbycolor_icon.jpg ) or by rattling the shortcut key Shift+O.

Common uses

In terms of functionality, the Select by Color tool is similar to the Fuzzy Select tool, but the major difference between these two tools is that Select by Color tool selects all regions in the image which have similar pixel properties, whereas the Fuzzy Select tool only selects the regions which are contiguous with respect to the point where we clicked on the image. To make things more clear, let us take the case of the four colored rectangles again. When I click on the red rectangle (the one at the top) using the Select by Color tool, not only will the top rectangle get selected but the one in the bottom (which is painted in the same shade of red) will also get selected. This is illustrated in the image below.

selectbycolor.jpg

You must note that in this selection, the two (red) rectangles are independently selected, i.e. if I use the Bucket fill paint tool and paint the bigger (red) rectangle, the smaller one is un-affected.

Get GIMP's official Documentation

The GIMP's official documentation is available in two formats - html, pdf. You may get a copy of it yourself by going to http://docs.gimp.org/2.4/. Happy GIMPing.


CategoryOutdated

Documentation/GIMP (last edited 2013-08-30 16:25:50 by FelipeLopez)