Outdated documentation

This page is out of date. Please use the main navigation to find the latest documentation.

Note: these installation guidelines apply to gNewSense deltah only.

VLC is not in gNewSense repositories because Ubuntu decided to classify it under multiverse software repository, due to legal issues in some countries (Check if VLC is illegal in your country before installing).

However it is free software and can be installed using the PPA from https://launchpad.net/~c-korn/+archive/vlc. The procedure is as follows:

Download libx264-57 from Ubuntu, choose a mirror from:

 http://packages.ubuntu.com/hardy/i386/libx264-57/download

Once you have downloaded the package, use the dkpg command:

 dpkg -i libx264-57_0.svn20071224-0.0ubuntu1_i386.deb

Or double-click and install.

Open a terminal and type:

 sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 7613768D

This import the key for apt-get to check that it has not been modified since publishing. After doing this, you should type:

 sudo gedit /etc/apt/sources.list

This opens a text editor with apt-get preferences, you have to add those two lines:

 deb http://ppa.launchpad.net/c-korn/vlc/ubuntu hardy main 
 deb-src http://ppa.launchpad.net/c-korn/vlc/ubuntu hardy main

You have added the repository from vlc and should update:

 sudo apt-get update

Now you can install VLC from repository using synaptic or typing:

 sudo apt-get install vlc

You should have a working VLC on gNewSense.


CategoryOutdated

Documentation/InstallingVLC (last edited 2013-08-30 02:34:16 by FelipeLopez)